WPAdmin AWS CDN <= 2.0.13 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-37889
CVSS 4.3 (Medium)
Publicly Published July 11, 2023
Last Updated August 10, 2023
Researcher Mika


The WPAdmin AWS CDN plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0.13. This is due to missing nonce validation on several functions called via AJAX actions in the /admin/class-aws-cdn-admin.php file. This makes it possible for unauthenticated attackers to perform several unauthorized actions like managing cdn, certificate, domain, and exclusion settings for the plugin via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug aws-cdn-by-wpadmin (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.0.0, or a newer patched version
Affected Version
  • <= 2.0.13
Patched Version
  • 3.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.