Backup Migration <= 1.3.9 - Authenticated (Admin+) OS Command Injection via url

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')
CVE CVE-2023-7002
CVSS 7.2 (High)
Publicly Published December 22, 2023
Last Updated January 22, 2024
Researcher Françoa Taffarel


The Backup Migration plugin for WordPress is vulnerable to OS Command Injection in all versions up to, and including, 1.3.9 via the 'url' parameter. This vulnerability allows authenticated attackers, with administrator-level permissions and above, to execute arbitrary commands on the host operating system.



1 affected software package

Software Type Plugin
Software Slug backup-backup (view on
Patched? Yes
Remediation Update to version 1.4.0, or a newer patched version
Affected Version
  • <= 1.3.9
Patched Version
  • 1.4.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.