BackupWordPress <= 3.12 - Missing Authorization to Authenticated (Subscriber+) Information Disclosure

4.3
Missing Authorization
CVE CVE-2022-4931
CVSS 4.3 (Medium)
Publicly Published February 23, 2022
Last Updated March 7, 2023
Researcher Ram - Wordfence

Description

The BackupWordPress plugin for WordPress is vulnerable to information disclosure in versions up to, and including 3.12. This is due to missing authorization on the heartbeat_received() function that triggers on WordPress heartbeat. This makes it possible for authenticated attackers, with subscriber-level permissions and above to retrieve back-up paths that can subsequently be used to download the back-up.

Wordfence blocked 215 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for BackUpWordPress

Software Type Plugin
Software Slug backupwordpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.13, or a newer patched version
Affected Version
  • 3.12 - 3.12
Patched Version
  • 3.13

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation