BackUpWordPress <= 3.13 - Authenticated (Admin+) Directory Traversal

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2024-3034
CVSS 2.7 (Low)
Publicly Published April 26, 2024
Last Updated April 27, 2024
Researcher dk0pf - Plumeria Lab


The BackUpWordPress plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 3.13 via the hmbkp_directory_browse parameter. This makes it possible for authenticated attackers, with administrator-level access and above, to traverse directories outside of the context in which the plugin should allow.



Vulnerability Details for BackUpWordPress

Software Type Plugin
Software Slug backupwordpress (view on
Patched? Yes
Remediation Update to version 3.14, or a newer patched version
Affected Version
  • <= 3.13
Patched Version
  • 3.14

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.