BackWPup <= 4.0.1 - Authenticated (Administrator+) Directory Traversal

8.7
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-5504
CVSS 8.7 (High)
Publicly Published November 22, 2023
Last Updated January 22, 2024
Researcher Marco Wotschka - Wordfence

Description

The BackWPup plugin for WordPress is vulnerable to Directory Traversal in versions up to, and including, 4.0.1 via the Log File Folder. This allows authenticated attackers to store backups in arbitrary folders on the server provided they can be written to by the server. Additionally, default settings will place an index.php and a .htaccess file into the chosen directory (unless already present) when the first backup job is run that are intended to prevent directory listing and file access. This means that an attacker could set the backup directory to the root of another site in a shared environment and thus disable that site.

References

Share

Vulnerability Details for BackWPup – WordPress Backup Plugin

Software Type Plugin
Software Slug backwpup (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.2, or a newer patched version
Affected Version
  • <= 4.0.1
Patched Version
  • 4.0.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation