Element Pack Elementor Addons <= 5.4.11 - Missing Authorization via bdt_duplicate_as_draft

4.3
Missing Authorization
CVE CVE-2024-24840
CVSS 4.3 (Medium)
Publicly Published February 2, 2024
Last Updated February 5, 2024
Researcher Abu Hurayra (HurayraIIT) - WPDeveloper

Description

The Element Pack Elementor Addons plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'bdt_duplicate_as_draft' function in versions up to, and including, 5.4.11. This makes it possible for authenticated attackers, with contributor-level access and above, to duplicate other user's posts and set their user as the author of the duplicated post.

References

Share

1 affected software package

Software Type Plugin
Software Slug bdthemes-element-pack-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.4.12, or a newer patched version
Affected Version
  • <= 5.4.11
Patched Version
  • 5.4.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation