Beaver Builder – WordPress Page Builder (Free & Pro) <= 1.7 - Authorization Bypass

Missing Authorization
CVSS 6.3 (Medium)
Publicly Published February 8, 2016
Last Updated January 22, 2024
Researcher James Golovich


The Beaver Builder – WordPress Page Builder plugin for WordPress is vulnerable to authorization bypass in versions up to, and including, 1.7 due to bypass in how the capability checking functionality works in the call_action() function. An attacker is able to supply '0' for the 'post_id' parameter which makes the check that a current user can edit the supplied post ID true. This makes it possible for authenticated attackers, with minimal permissions like a subscriber, to call any of the 40+ AJAX action available and perform many unauthorized actions.



Vulnerability Details for Beaver Builder – WordPress Page Builder

Software Type Plugin
Software Slug beaver-builder-lite-version (view on
Patched? Yes
Remediation Update to version 1.7.1, or a newer patched version
Affected Version
  • <= 1.7
Patched Version
  • 1.7.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.