Better Search Replace <= 1.4 - Authenticated (Administrator+) SQL Injection

7.2
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2022-2593
CVSS 7.2 (High)
Publicly Published August 1, 2022
Last Updated January 22, 2024
Researcher Christiaan Swiers

Description

The plugin Better Search Replace for WordPress is vulnerable to SQL Injection in versions up to, and including, 1.4. This is due to lack of sanitization of user input in the construction of a database query. This makes it possible for authenticated attackers with administrator-level accounts to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

References

Share

1 affected software package

Software Type Plugin
Software Slug better-search-replace (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.4.1, or a newer patched version
Affected Version
  • <= 1.4
Patched Version
  • 1.4.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation