Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-33999
CVSS 6.1 (Medium)
Publicly Published July 18, 2023
Last Updated April 8, 2024
Researcher Rafie Muhammad - Patchstack

Description

The Freemius SDK for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘fs_request_get’ function in versions up to, and including, 2.5.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Blockspare – Expertly Crafted Patterns & Page Builder Gutenberg Blocks for Blog, Magazine, Newspaper, and Business Sites. One-click Import, No Coding Hassle!

Software Type Plugin
Software Slug blockspare (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.5, or a newer patched version
Affected Version
  • <= 2.6.4
Patched Version
  • 2.6.5

1-20 of 757 other affected software packages

Search affected software packages

Software Type Plugin
Software Slug 1-click-close-store (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • 1.1.0 - 1.1.0
Software Type Plugin
Software Slug 2mb-autocode (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.6, or a newer patched version
Affected Version
  • <= 1.2.5
Patched Version
  • 1.2.6
Software Type Plugin
Software Slug 3d-viewer (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.4, or a newer patched version
Affected Version
  • <= 1.3.3
Patched Version
  • 1.3.4
Software Type Plugin
Software Slug 404-to-301 (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.0.6, or a newer patched version
Affected Version
  • <= 3.0.5
Patched Version
  • 3.0.6
Software Type Plugin
Software Slug setka-editor (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • 1.9.1 - 2.1.19
Software Type Plugin
Software Slug a-staff (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • 1.2 - 1.2.2
Software Type Plugin
Software Slug auto-date-year-month (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • 1.0.1 - 1.1.2
Software Type Plugin
Software Slug wp-stripe-donation (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.2.1, or a newer patched version
Affected Version
  • <= 3.2.0
Patched Version
  • 3.2.1
Software Type Plugin
Software Slug acf-for-woocommerce-product (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • 0.1 - 1.8.1
Software Type Plugin
Software Slug acf-vc-integrator (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.1, or a newer patched version
Affected Version
  • <= 1.3.0
Patched Version
  • 1.3.1
Software Type Plugin
Software Slug pramadillo-activecampaign-email-preference-center (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0.12, or a newer patched version
Affected Version
  • 1.0.0 - 2.0.11
Patched Version
  • 2.0.12
Software Type Plugin
Software Slug activity-log-mainwp (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0.0, or a newer patched version
Affected Version
  • <= 1.7.1
Patched Version
  • 2.0.0
Software Type Plugin
Software Slug adblock-notify-by-bweb (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • 2.0.8 - 2.4.0
Software Type Plugin
Software Slug add-expires-headers (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.8.0, or a newer patched version
Affected Version
  • 2.0 - 2.7.3
Patched Version
  • 2.8.0
Software Type Plugin
Software Slug advance-menu-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.0.6, or a newer patched version
Affected Version
  • 3.0.1 - 3.0.5
Patched Version
  • 3.0.6
Software Type Plugin
Software Slug advanced-classifieds-and-directory-pro (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.2, or a newer patched version
Affected Version
  • <= 2.1.1
Patched Version
  • 2.1.2
Software Type Plugin
Software Slug buddyforms-acf (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.5, or a newer patched version
Affected Version
  • <= 1.3.4
Patched Version
  • 1.3.5
Software Type Plugin
Software Slug advanced-database-replacer (view on wordpress.org)
Patched? No
Remediation No known patch available. Please review the vulnerability's details in depth and employ mitigations based on your organization's risk tolerance. It may be best to uninstall the affected software and find a replacement.
Affected Version
  • 1.0.0 - 1.1.0
Software Type Plugin
Software Slug advanced-form-integration (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.69.1, or a newer patched version
Affected Version
  • <= 1.69.0
Patched Version
  • 1.69.1
Software Type Plugin
Software Slug advanced-page-visit-counter (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.1.1, or a newer patched version
Affected Version
  • 3.0 - 7.1.0
Patched Version
  • 7.1.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation