Blocksy Companion <= 1.8.81 - Authenticated(Subscriber+) Sensitive Information Exposure via blocksy_posts shortcode

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-1911
CVSS 4.3 (Medium)
Publicly Published April 10, 2023
Last Updated April 14, 2023
Researcher Erwan LR - WPScan


The Blocksy Companion plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.8.81 via the blocksy_posts shortcode. This can allow authenticated attackers with subscriber-level permissions or above to extract sensitive data including draft posts.



1 affected software package

Software Type Plugin
Software Slug blocksy-companion (view on
Patched? Yes
Remediation Update to version 1.8.82, or a newer patched version
Affected Version
  • <= 1.8.81
Patched Version
  • 1.8.82

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.