Blog2Social <= 6.9.9 - Authenticated (Subscriber+) Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2022-3247
CVSS 7.4 (High)
Publicly Published October 3, 2022
Last Updated January 22, 2024
Researcher Saggre


The Blog2Social plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 6.9.9 due to missing URL validation to ensure an external URL is used in the function b2sFileGetContents. This makes it possible for authenticated users, with subscriber-level access or higher, to perform attacks against the server.



Vulnerability Details for Blog2Social: Social Media Auto Post & Scheduler

Software Type Plugin
Software Slug blog2social (view on
Patched? Yes
Remediation Update to version 6.9.10, or a newer patched version
Affected Version
  • <= 6.9.9
Patched Version
  • 6.9.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.