Better Notifications for WP <= 1.9.2 - Cross-Site Request Forgery via handle_actions

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-32964
CVSS 4.3 (Medium)
Publicly Published May 18, 2023
Last Updated May 22, 2023
Researcher Nguyen Xuan Chien


The Better Notifications for WP plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.9.2. This is due to missing or incorrect nonce validation on the handle_actions function. This makes it possible for unauthenticated attackers to enable or disable notifications via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Customize WordPress Emails and Alerts – Better Notifications for WP

Software Type Plugin
Software Slug bnfw (view on
Patched? Yes
Remediation Update to version 1.9.3, or a newer patched version
Affected Version
  • <= 1.9.2
Patched Version
  • 1.9.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.