BoldGrid Easy SEO – Simple and Effective SEO <= 1.6.14 - Information Exposure

Information Exposure
CVE CVE-2024-2950
CVSS 5.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 6, 2024
Researcher Krzysztof Zając - CERT PL


The BoldGrid Easy SEO – Simple and Effective SEO plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.6.14 via meta information (og:description) This makes it possible for unauthenticated attackers to view the first 130 characters of a password protected post which can contain sensitive information.



Vulnerability Details for BoldGrid Easy SEO – Simple and Effective SEO

Software Type Plugin
Software Slug boldgrid-easy-seo (view on
Patched? Yes
Remediation Update to version 1.6.15, or a newer patched version
Affected Version
  • <= 1.6.14
Patched Version
  • 1.6.15

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.