Booked <= 2.2.5 - Missing Authorization on AJAX Actions

8.8
Missing Authorization
CVSS 8.8 (High)
Publicly Published February 29, 2020
Last Updated January 22, 2024
Researcher Noman Riffat

Description

The Booked plugin for WordPress is vulnerable to authorization bypass due to missing capability checks on several functions hooked via AJAX actions in versions up to, and including, 2.2.5. This makes it possible for authenticated attackers with subscriber-level permissions and above to execute several unauthorized actions.

References

Share

1 affected software package

Software Type Plugin
Software Slug booked
Patched? Yes
Remediation Update to version 2.2.6, or a newer patched version
Affected Version
  • < 2.2.6
Patched Version
  • 2.2.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation