Booking Package <= 1.5.98 - Authorization Bypass to Arbitrary Password Reset

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-37389
CVSS 9.8 (Critical)
Publicly Published July 5, 2023
Last Updated July 13, 2023
Researcher Rafie Muhammad - Patchstack


The Booking Package plugin for WordPress is vulnerable to Authorization Bypass in versions up to, and including 1.5.98 due to missing validation in the 'updateUser' function. This allows unauthenticated attackers to reset the email and password of any user on the site if they know the username. Note that only sites that have an active premium subscription are vulnerable.



Vulnerability Details for Booking Package

Software Type Plugin
Software Slug booking-package (view on
Patched? Yes
Remediation Update to version 1.5.99, or a newer patched version
Affected Version
  • < 1.5.99
Patched Version
  • 1.5.99

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.