Booking Ultra Pro <= 1.1.8 - Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-36854
CVSS 6.4 (Medium)
Publicly Published September 29, 2022
Last Updated August 10, 2023
Researcher Ngo Van Thien - Patchstack Alliance


The Booking Ultra Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in versions up to, and including, 1.1.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This can also be exploited via CSRF.



1 affected software package

Software Type Plugin
Software Slug booking-ultra-pro (view on
Patched? Yes
Remediation Update to version 1.1.9, or a newer patched version
Affected Version
  • <= 1.1.8
Patched Version
  • 1.1.9

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.