Booking Ultra Pro <= 1.1.6 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2021-36854
CVSS 8.8 (High)
Publicly Published September 29, 2022
Last Updated July 18, 2023
Researcher Ngo Van Thien


The Booking Ultra Pro plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.6. This is due to missing or incorrect nonce validation on most AJAX actions. This makes it possible for unauthenticated attackers to inject malicious JavaScript, obtain information about staff users, change opening times and more, via forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Booking Ultra Pro Appointments Booking Calendar Plugin

Software Type Plugin
Software Slug booking-ultra-pro (view on
Patched? Yes
Remediation Update to version 1.1.7, or a newer patched version
Affected Version
  • <= 1.1.6
Patched Version
  • 1.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.