BookingPress <= 1.0.72 - Authenticated (Contributor+) SQL Injection

8.8
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2023-50841
CVSS 8.8 (High)
Publicly Published December 21, 2023
Last Updated January 22, 2024
Researcher Ngô Thiên An (ancorn_) - VNPT-VCI

Description

The BookingPress – Appointment Booking Calendar Plugin and Online Scheduling Plugin plugin for WordPress is vulnerable to SQL Injection via an unknown parameter in all versions up to, and including, 1.0.72 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor level or higher, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

References

Share

Vulnerability Details for Appointment Booking Calendar Plugin and Online Scheduling Plugin – BookingPress

Software Type Plugin
Software Slug bookingpress-appointment-booking (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.73, or a newer patched version
Affected Version
  • <= 1.0.72
Patched Version
  • 1.0.73

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation