BookingPress <= 1.0.74 - Booking Price Manipulation via bookingpress_confirm_booking

7.5
Improper Input Validation
CVE CVE-2023-51405
CVSS 7.5 (High)
Publicly Published December 27, 2023
Last Updated January 22, 2024
Researcher Abdi Pranata

Description

The BookingPress plugin for WordPress is vulnerable to booking price manipulation in all versions up to, and including, 1.0.74. This is due to insufficient validation checks within the bookingpress_confirm_booking function. This makes it possible for unauthenticated attackers to to modify the price of an appointment.

References

Share

Vulnerability Details for Appointment Booking Calendar Plugin and Online Scheduling Plugin – BookingPress

Software Type Plugin
Software Slug bookingpress-appointment-booking (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.75, or a newer patched version
Affected Version
  • <= 1.0.74
Patched Version
  • 1.0.75

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation