BookingPress <= 1.0.81 - Authenticated (Customer+) Insecure Direct Object Reference

4.3
Authorization Bypass Through User-Controlled Key
CVE CVE-2024-31296
CVSS 4.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Steven Julian

Description

The BookingPress – Appointment Booking Calendar Plugin and Online Scheduling Plugin plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.0.81 due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with customer-level access and above, to access or perform an action on an object they should not have access to.

References

Share

Vulnerability Details for BookingPress – Appointment Booking Calendar Plugin and Online Scheduling Plugin

Software Type Plugin
Software Slug bookingpress-appointment-booking (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.82, or a newer patched version
Affected Version
  • <= 1.0.81
Patched Version
  • 1.0.82

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation