BookIt <=2.4.0 - Price Bypass

Improper Authorization
CVE CVE-2024-24715
CVSS 4.9 (Medium)
Publicly Published January 31, 2024
Last Updated February 2, 2024
Researchers Debangshu Kundu
Arpeet Rathi


The Booking Calendar | Appointment Booking | BookIt plugin for WordPress is vulnerable to Price Bypass in versions up to and including 2.4.0. This makes it possible for site owners to make use of premium plugin features without paying. Note that this does not meaningfully negatively impact site owners themselves.



1 affected software package

Software Type Plugin
Software Slug bookit (view on
Patched? Yes
Remediation Update to version 2.4.1, or a newer patched version
Affected Version
  • <= 2.4.0
Patched Version
  • 2.4.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.