Bookly <= 21.5 - Unauthenticated Stored Cross-Site Scripting via Name

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-1172
CVSS 7.2 (High)
Publicly Published March 17, 2023
Last Updated January 22, 2024
Researcher Vinay Kumar


The Bookly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the full name value in versions up to, and including, 21.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for WordPress Online Booking and Scheduling Plugin – Bookly

Software Type Plugin
Software Slug bookly-responsive-appointment-booking-tool (view on
Patched? Yes
Remediation Update to version 21.5.1, or a newer patched version
Affected Version
  • 21.5 - 21.5
Patched Version
  • 21.5.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.