Bookly <= 21.7.1 - Arbitrary File Deletion

Missing Authorization
CVE CVE-2023-26526
CVSS 8.1 (High)
Publicly Published May 11, 2023
Last Updated May 17, 2023
Researcher Rafie Muhammad - Patchstack


The Bookly plugin for WordPress is vulnerable to arbitrary file deletion in versions up to, and including, 21.7.1. This makes it possible for authenticated attackers with staff-level access to delete arbitrary files on the affected site's server which may make a site takeover possible.



Vulnerability Details for WordPress Online Booking and Scheduling Plugin – Bookly

Software Type Plugin
Software Slug bookly-responsive-appointment-booking-tool (view on
Patched? Yes
Remediation Update to version 21.8, or a newer patched version
Affected Version
  • <= 21.7.1
Patched Version
  • 21.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.