WordPress Online Booking and Scheduling Plugin – Bookly <= 23.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Color Profile Parameter

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-5584
CVSS 6.4 (Medium)
Publicly Published June 10, 2024
Last Updated June 11, 2024
Researcher 0xBishop


The WordPress Online Booking and Scheduling Plugin – Bookly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Color Profile parameter in all versions up to, and including, 23.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with the staff member role and Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for WordPress Online Booking and Scheduling Plugin – Bookly

Software Type Plugin
Software Slug bookly-responsive-appointment-booking-tool (view on wordpress.org)
Patched? Yes
Remediation Update to version 23.3, or a newer patched version
Affected Version
  • <= 23.2
Patched Version
  • 23.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.