Booster Extension <= 1.2.0 - Basic Information Exposure via booster_extension_authorbox_shortcode_display

Missing Authorization
CVE CVE-2024-2109
CVSS 5.3 (Medium)
Publicly Published April 29, 2024
Last Updated May 31, 2024
Researcher Krzysztof Zając - CERT PL


The Booster Extension plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.2.0 via the 'booster_extension_authorbox_shortcode_display' function. This makes it possible for unauthenticated attackers to extract sensitive data including user emails



Vulnerability Details for Booster Extension

Software Type Plugin
Software Slug booster-extension (view on
Patched? Yes
Remediation Update to version 1.2.1, or a newer patched version
Affected Version
  • <= 1.2.0
Patched Version
  • 1.2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.