Better Messages <= 1.9.9.148 - Cross-Site Request Forgery

8.8
Cross-Site Request Forgery (CSRF)
CVE CVE-2022-36389
CVSS 8.8 (High)
Publicly Published January 18, 2022
Last Updated February 1, 2023
Researcher Vladislav Pokrovsky (ΞX.MI) - Independent AppSec Researcher

Description

The Better Messages plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.9.9.148. This is due to missing or incorrect nonce validation on the bp_messages_favorite action. This makes it possible for unauthenticated attackers to trigger this action granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Better Messages – Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss

Software Type Plugin
Software Slug bp-better-messages (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.9.9.149, or a newer patched version
Affected Version
  • <= 1.9.9.148
Patched Version
  • 1.9.9.149

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation