Breakdance <= 1.7.1 - Authenticated (Contributor+) Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2024-4605
CVSS 8.8 (High)
Publicly Published May 8, 2024
Last Updated May 9, 2024
Researcher Francesco Carlucci


The Breakdance plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.7.1 via post meta data. This is due to the plugin storing custom data in metadata without an underscore prefix. This makes it possible for lower privileged users, such as contributors, to edit this data via UI. As a result they can escalate their privileges or execute arbitrary code.



Vulnerability Details for Breakdance

Software Type Plugin
Software Slug breakdance
Patched? Yes
Remediation Update to version 1.7.2, or a newer patched version
Affected Version
  • <= 1.7.1
Patched Version
  • 1.7.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.