Bricks Builder <= 1.9.8 - Insecure Direct Object Reference

Authorization Bypass Through User-Controlled Key
CVE CVE-2024-4874
CVSS 4.3 (Medium)
Publicly Published June 21, 2024
Last Updated June 22, 2024
Researcher Francesco Carlucci


The Bricks Builder plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.9.8 via the postId parameter due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Contributor-level access and above, to modify posts and pages created by other users including admins. As a requirement for this, an admin would have to enable access to the editor specifically for such a user or enable it for all users with a certain user account type.



Vulnerability Details for Bricks Builder

Software Type Plugin
Software Slug bricksbuilder
Patched? Yes
Remediation Update to version 1.9.9, or a newer patched version
Affected Version
  • <= 1.9.8
Patched Version
  • 1.9.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.