Brizy – Page Builder <= 2.4.39 - Authenticated (Contributor+) Directory Traversal

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2024-1165
CVSS 4.3 (Medium)
Publicly Published February 23, 2024
Last Updated February 24, 2024
Researcher wesley (wcraft)


The Brizy – Page Builder plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.4.39 via the 'id'. This makes it possible for authenticated attackers, with contributor-level access and above, to upload files to arbitrary locations on the server



Vulnerability Details for Brizy – Page Builder

Software Type Plugin
Software Slug brizy (view on
Patched? Yes
Remediation Update to version 2.4.41, or a newer patched version
Affected Version
  • <= 2.4.40
Patched Version
  • 2.4.41

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.