Broken Link Checker <= 1.11.8 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2019-17207
CVSS 5.4 (Medium)
Publicly Published October 14, 2019
Last Updated November 15, 2022
Researcher Tobias Fink


A reflected XSS vulnerability was found in includes/admin/table-printer.php in the Broken Link Checker plugin 1.11.8 for WordPress. This allows unauthorized users to inject client-side JavaScript into an admin-only WordPress page via the wp-admin/tools.php?page=view-broken-links s_filter parameter in a search action.



Vulnerability Details for Broken Link Checker

Software Type Plugin
Software Slug broken-link-checker (view on
Patched? Yes
Remediation Update to version 1.11.9, or a newer patched version
Affected Version
  • < 1.11.9
Patched Version
  • 1.11.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.