BuddyForms <= 2.7.2 - Authenticated (Contributor+) Stored Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-38971
CVSS 6.4 (Medium)
Publicly Published October 27, 2022
Last Updated January 22, 2024
Researcher Ngo Van Thien - Patchstack Alliance


The BuddyForms plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.7.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Post Form – Registration Form – Profile Form for User Profiles – Frontend Content Forms for User Submissions (UGC)

Software Type Plugin
Software Slug buddyforms (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.7.3, or a newer patched version
Affected Version
  • <= 2.7.2
Patched Version
  • 2.7.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.