BuddyPress

Information

Software Type Plugin
Software Slug buddypress (view on wordpress.org)
Software Status Active
Software Author buddypress
Software Website buddypress.org
Software Downloads 12,721,045
Software Active Installs 100,000
Software Record Last Updated May 18, 2024

20 Vulnerabilities

9.8
CVE ID Unknown
Aug 18, 2021
Researcher: David Cavins
8.8
CVE ID Unknown
Aug 18, 2021
Researcher: Brajesh Singh
8.8
CVE ID Unknown
Apr 14, 2021
Researcher: Kien Hoang
5.4
CVE ID Unknown
Mar 17, 2021
Researcher: Kien Hoang
4.6
CVE ID Unknown
Mar 16, 2021
Researchers:
6.4
CVE ID Unknown
Nov 27, 2020
Researchers:
5.4
CVE ID Unknown
Dec 23, 2019
Researcher: nomnom
8.8
CVE ID Unknown
Nov 11, 2015
Researcher: Slava Abakumov
Title Status CVE ID CVSS Researchers Date
BuddyPress <= 12.4.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting Patched CVE-2024-3974 6.4 wesley (wcraft) May 3, 2024
BuddyPress <= 11.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting Patched CVE-2023-50880 6.4 Rafie Muhammad December 26, 2023
BuddyPress <= 9.0.0 - SQL Injection Patched 9.8 David Cavins August 18, 2021
BuddyPress <= 9.0.0 - Information Disclosure via REST API Patched 8.8 Brajesh Singh August 18, 2021
BuddyPress <= 7.2.1 - Missing Authorization to Group Creation Patched 5.4 Kien Hoang April 14, 2021
BuddyPress <= 7.2.1 - Insufficient Privilege De-escalation Patched 8.8 Kien Hoang April 14, 2021
BuddyPress <= 7.2.1 - Missing Authorization to Private Post Activity Patched 5.4 Kien Hoang April 14, 2021
BuddyPress <= 7.2.1 - Missing Authorization to Unauthorized Group Access Patched 5.4 Kien Hoang April 14, 2021
BuddyPress <= 7.2.0 - Authorization Bypass to Friend Invite Patched 5.4 Kien Hoang March 17, 2021
BuddyPress - 7.0.0 - 7.2.0 - Insufficient Privilege De-escalation Patched 4.6 March 16, 2021
BuddyPress 5.0.0-7.2.0 - Privilege Escalation via REST API Patched CVE-2021-21389 8.8 Kien March 16, 2021
BuddyPress <= 7.2.0 - Authorization Bypass to Private Message Disclosure Patched 6.5 Kien Hoang March 7, 2021
BuddyPress <= 6.3.0 - Insufficient Input Validation Patched 6.4 November 27, 2020
BuddyPress <= 5.1.1 - Sensitive Information Disclosure Patched CVE-2020-5244 7.5 Petter Walbø Johnsgård, Jacek Suski January 2, 2020
BuddyPress <= 5.1.0 - Denial of Service Patched 5.4 nomnom December 23, 2019
BuddyPress 2.0 - 2.7.3 - Unauthenticated Arbitrary File Deletion Patched 10.0 Sam Pizzey (mopman) December 23, 2016
BuddyPress <= 2.3.4 - Privilege Escalation Patched 8.8 Slava Abakumov November 11, 2015
BuddyPress <= 1.9.1 - Stored Cross-Site Scripting Patched CVE-2014-1888 6.4 Pietro Oliva August 1, 2014
BuddyPress <= 1.9.1 - Authorization Bypass Patched CVE-2014-1889 6.5 Pietro Oliva February 5, 2014
BuddyPress - 1.5-1.5.4 - SQL Injection Patched CVE-2012-2109 9.8 Ivan Terkin March 27, 2012

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation