Announcement & Notification Banner – Bulletin <= 3.7.0 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-2067
CVSS 6.3 (Medium)
Publicly Published May 11, 2023
Last Updated June 9, 2023
Researcher Chloe Chamberland - Wordfence


The Announcement & Notification Banner – Bulletin plugin for WordPress is vulnerable to Cross-Site Request Forgery due to a missing nonce validation on the 'bulletinwp_update_bulletin_status', 'bulletinwp_update_bulletin', 'bulletinwp_update_settings', 'bulletinwp_update_status', 'bulletinwp_export_bulletins', and 'bulletinwp_import_bulletins' functions in versions up to, and including, 3.7.0. This makes it possible for unauthenticated attackers to modify the plugin's settings, modify bulletins, create new bulletins, and more, via a forged request granted they can trick a site's user into performing an action such as clicking on a link.



Vulnerability Details for Announcement & Notification Banner – Bulletin

Software Type Plugin
Software Slug bulletin-announcements (view on
Patched? Yes
Remediation Update to version 3.7.1, or a newer patched version
Affected Version
  • <= 3.7.0
Patched Version
  • 3.7.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.