Button Generator – easily Button Builder <= 2.3.5 - Cross-Site Request Forgery in tools-data-base.php

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-25443
CVSS 5.3 (Medium)
Publicly Published May 25, 2023
Last Updated June 7, 2023
Researcher Rio Darmawan - Zerobyte


The Button Generator – easily Button Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.3.5. This is due to missing or incorrect nonce validation in the tools-data-base.php file. This makes it possible for unauthenticated attackers to delete buttons via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Button Generator – easily Button Builder

Software Type Plugin
Software Slug button-generation (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.3.6, or a newer patched version
Affected Version
  • <= 2.3.5
Patched Version
  • 2.3.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.