Buy Me a Coffee – Button and Widget Plugin <= 3.7 - Missing Authorization

Missing Authorization
CVE CVE-2023-2078
CVSS 7.3 (High)
Publicly Published July 10, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The "Buy Me a Coffee – Button and Widget Plugin" plugin for WordPress is vulnerable to unauthorized modification of data due to missing capability checks on the recieve_post, bmc_disconnect, name_post, and widget_post functions in versions up to, and including, 3.7. This makes it possible for authenticated attackers, with minimal permissions such as subscribers, to update the plugins settings. CVE-2023-25030 may be a duplicate of this issue.



Vulnerability Details for Buy Me a Coffee – Button and Widget Plugin

Software Type Plugin
Software Slug buymeacoffee (view on
Patched? Yes
Remediation Update to version 3.8, or a newer patched version
Affected Version
  • <= 3.7
Patched Version
  • 3.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.