Calendar <= 1.3.14 - Authenticated (Contributor+) SQL Injection via Shortcode

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2024-2831
CVSS 8.8 (High)
Publicly Published April 29, 2024
Last Updated June 5, 2024
Researcher Krzysztof Zając - CERT PL


The Calendar plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcodes in all versions up to, and including, 1.3.14 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor access or higher, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



Vulnerability Details for Calendar

Software Type Plugin
Software Slug calendar (view on
Patched? Yes
Remediation Update to version 1.3.15, or a newer patched version
Affected Version
  • <= 1.3.14
Patched Version
  • 1.3.15

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.