CartFlows <= 1.11.11 - Insecure Direct Object Reference to Arbitrary Post Deletion

Authorization Bypass Through User-Controlled Key
CVSS 2.7 (Low)
Publicly Published June 2, 2023
Last Updated June 12, 2023


The CartFlows plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions up to, and including, 1.11.11. This is due to the fact that during cart flow deletion/modification, the plugin does not verify that the flow ID provided to the AJAX action is indeed a cart flow id. This makes it possible for authenticated attackers, with cart flow manager access or higher, to modify or delete arbitrary posts. This permission is by default available to admins, but can be given to other user types.



1 affected software package

Software Type Plugin
Software Slug cartflows (view on
Patched? Yes
Remediation Update to version 1.11.12, or a newer patched version
Affected Version
  • < 1.11.12
Patched Version
  • 1.11.12

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.