Simple SEO <= 1.8.12 - Cross-Site Request Forgery to Sitemap Deletion/Creation

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-36404
CVSS 8.8 (High)
Publicly Published October 20, 2022
Last Updated January 22, 2024
Researcher Mika - Patchstack Alliance


The Simple SEO plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.8.12. This is due to missing or incorrect nonce validation. This makes it possible for unauthenticated attackers to create or delete sitemaps, via forged request granted they can trick a site administrator into performing an action such as clicking on a link. CVE-2022-44627 is a duplicate.



1 affected software package

Software Type Plugin
Software Slug cds-simple-seo (view on
Patched? Yes
Remediation Update to version 1.8.13, or a newer patched version
Affected Version
  • <= 1.8.12
Patched Version
  • 1.8.13

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.