Simple SEO <= 2.0.25 - Cross-Site Request Forgery via multiple admin_post functions

5.4
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-45269
CVSS 5.4 (Medium)
Publicly Published October 6, 2023
Last Updated January 22, 2024
Researcher Mika

Description

The Simple SEO plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0.25. This is due to missing or incorrect nonce validation on multiple admin_post functions. This makes it possible for unauthenticated attackers to import SEO content from other plugins as well as generate and delete sitemaps via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug cds-simple-seo (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0.26, or a newer patched version
Affected Version
  • <= 2.0.25
Patched Version
  • 2.0.26

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation