Geo Controller <= 8.6.4 - Unauthenticated PHP Object Injection via shortcode REST API Route

Deserialization of Untrusted Data
CVSS 8.8 (High)
Publicly Published February 10, 2024
Last Updated February 19, 2024


The Geo Controller plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 8.6.4 via deserialization of untrusted input supplied via the '/cache/shortcode' REST API route. This makes it possible for unauthenticated attackers to inject a PHP Object. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



1 affected software package

Software Type Plugin
Software Slug cf-geoplugin (view on
Patched? Yes
Remediation Update to version 8.6.5, or a newer patched version
Affected Version
  • <= 8.6.4
Patched Version
  • 8.6.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.