Void Contact Form 7 Widget For Elementor Page Builder <= 2.1.1 - Cross-Site Request Forgery in void_cf7_opt_in_user_data_track

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-47166
CVSS 4.3 (Medium)
Publicly Published February 12, 2023
Last Updated February 16, 2023
Researcher Muhammad Daffa


The Void Contact Form 7 Widget For Elementor Page Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.1.1. This is due to missing or incorrect nonce validation on the void_cf7_opt_in_user_data_track function via the admin_notices action. This makes it possible for unauthenticated attackers to perform an unauthorized feedback form submission via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Void Contact Form 7 Widget For Elementor Page Builder

Software Type Plugin
Software Slug cf7-widget-elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2, or a newer patched version
Affected Version
  • <= 2.1.1
Patched Version
  • 2.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.