AI ChatBot <= 4.4.7 - Missing Authorization on openai_settings_option_callback

5.4
Missing Authorization
CVSS 5.4 (Medium)
Publicly Published March 29, 2023
Last Updated March 29, 2023

Description

The AI ChatBot plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the openai_settings_option_callback function in versions up to, and including, 4.4.7. This makes it possible for subscriber-level attackers to change plugin settings.

References

Share

1 affected software package

Software Type Plugin
Software Slug chatbot (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.4.8, or a newer patched version
Affected Version
  • <= 4.4.7
Patched Version
  • 4.4.8

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation