AI ChatBot <= 4.8.9 and 4.9.2 - Authenticated (Subscriber+) Directory Traversal to Arbitrary File Write via qcld_openai_upload_pagetraining_file

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-5241
CVSS 9.6 (Critical)
Publicly Published October 11, 2023
Last Updated January 22, 2024
Researcher Marco Wotschka - Wordfence


The AI ChatBot for WordPress is vulnerable to Directory Traversal in versions up to, and including, 4.8.9 as well as 4.9.2 via the qcld_openai_upload_pagetraining_file function. This allows subscriber-level attackers to append "<?php" to any existing file on the server resulting in potential DoS when appended to critical files such as wp-config.php.



1 affected software package

Software Type Plugin
Software Slug chatbot (view on
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 4.9.1, 4.9.3
Affected Versions
  • 4.9.2 - 4.9.2
  • <= 4.8.9
Patched Versions
  • 4.9.1
  • 4.9.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.