AI ChatBot <= 4.8.9 and 4.9.2 - Cross-Site Request Forgery on AJAX actions

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-5534
CVSS 4.3 (Medium)
Publicly Published October 11, 2023
Last Updated October 23, 2023
Researcher Marco Wotschka - Wordfence


The AI ChatBot plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.8.9 and 4.9.2. This is due to missing or incorrect nonce validation on the corresponding functions. This makes it possible for unauthenticated attackers to invoke those functions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug chatbot (view on
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 4.9.1, 4.9.3
Affected Versions
  • 4.9.2 - 4.9.2
  • <= 4.8.9
Patched Versions
  • 4.9.1
  • 4.9.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.