Floating Chat Widget: Contact Icons, Messages, Telegram, Email, SMS, Call Button – Chaty <= 2.8.3 - Admin+ Stored Cross-Site Scripting

4.8
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-36846
CVSS 4.8 (Medium)
Publicly Published April 7, 2022
Last Updated January 22, 2024
Researcher Asif Nawaz Minhas - Patchstack Alliance

Description

Authenticated (admin or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in Premio Chaty (WordPress plugin) <= 2.8.3

References

Share

Vulnerability Details for Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button – Chaty

Software Type Plugin
Software Slug chaty (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.8.5, or a newer patched version
Affected Version
  • <= 2.8.3
Patched Version
  • 2.8.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation