Payment Gateway Based Fees and Discounts for WooCommerce <= 2.12.1 - Cross-Site Request Forgery to Notice Dismissal

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-33585
CVSS 4.3 (Medium)
Publicly Published April 25, 2024
Last Updated May 1, 2024
Researcher Dhabaleshwar Das


The Payment Gateway Based Fees and Discounts for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.12.1. This is due to missing or incorrect nonce validation on the dismiss_notice() function. This makes it possible for unauthenticated attackers to dismiss notices via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Payment Gateway Based Fees and Discounts for WooCommerce

Software Type Plugin
Software Slug checkout-fees-for-woocommerce (view on
Patched? Yes
Remediation Update to version 2.12.2, or a newer patched version
Affected Version
  • <= 2.12.1
Patched Version
  • 2.12.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.