Clerk <= 3.8.2 - Authorization Bypass via Insufficient Validation

Authorization Bypass Through User-Controlled Key
CVE CVE-2022-3907
CVSS 5.6 (Medium)
Publicly Published November 10, 2022
Last Updated January 30, 2023
Researcher Francesco Carlucci


The Clerk plugin for WordPress is vulnerable to Authorization Bypass via Insufficient Validation in versions up to, and including, 3.8.2. This is due to the validation function for all API requests using comparison operators to verify API keys against those stored in the site options. This leaves the API request validation vulnerable to time-based attacks. This makes it possible for unauthenticated attackers to potentially bypass API validation or to discover API keys.



1 affected software package

Software Type Plugin
Software Slug clerkio (view on
Patched? Yes
Remediation Update to version 3.8.3, or a newer patched version
Affected Version
  • <= 3.8.2
Patched Version
  • 3.8.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.