ClickCease Click Fraud Protection <= 3.2.4 - Improper Authorization to sensitive information exposure via get_settings

Improper Access Control
CVE CVE-2023-6810
CVSS 4.3 (Medium)
Publicly Published May 6, 2024
Last Updated May 7, 2024
Researcher Francesco Carlucci


The ClickCease Click Fraud Protection plugin for WordPress is vulnerable to unauthorized access of data due to an improper capability check on the get_settings function in all versions up to, and including, 3.2.4. This makes it possible for authenticated attackers, with author access and above, to retrieve the plugin's configured API keys.



Vulnerability Details for ClickCease Click Fraud Protection

Software Type Plugin
Software Slug clickcease-click-fraud-protection (view on
Patched? Yes
Remediation Update to version 3.2.5, or a newer patched version
Affected Version
  • <= 3.2.4
Patched Version
  • 3.2.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.