CMB2 <= 2.10.1 - Authenticated (Contributor+) PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2024-1792
CVSS 7.5 (High)
Publicly Published April 3, 2024
Last Updated April 9, 2024
Researcher Francesco Carlucci


The CMB2 plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.10.1 via deserialization of untrusted input from the text_datetime_timestamp_timezone field. This makes it possible for authenticated attackers, with contributor access or higher, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code. Please note that the plugin is a developer toolkit. For the vulnerability to become exploitable, the presence of a metabox activation in your code (via functions.php for example) is required.



Vulnerability Details for CMB2

Software Type Plugin
Software Slug cmb2 (view on
Patched? Yes
Remediation Update to version 2.11.0, or a newer patched version
Affected Version
  • <= 2.10.1
Patched Version
  • 2.11.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.