Code Snippets <= 3.5.0 - Cross-Site Request Forgery via load

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-47666
CVSS 5.4 (Medium)
Publicly Published November 6, 2023
Last Updated November 13, 2023
Researcher Huynh Tien Si


The Code Snippets plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to and including 3.5.0. This is due to missing or incorrect nonce validation on the load function. This makes it possible for unauthenticated attackers to reset plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug code-snippets (view on
Patched? Yes
Remediation Update to version 3.6.0, or a newer patched version
Affected Version
  • < 3.6.0
Patched Version
  • 3.6.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.